To stop the reverse engineering of script applications, a number of developers encrypt their program code with tools like ionCube PHP Encoder and make it human unreadable. The aforementioned is valid for paid apps in particular, because anyone would be able to use and modify the unprotected code without having to pay the required license fees. In case you acquire web software protected with ionCube PHP Encoder, you can use it without a problem as long as a software instrument known as ionCube Loader is available on the hosting server. This loader enables you to run encoded files and you will often see it on the list of prerequisites for a particular script application to be installed. Since the encrypted files are already precompiled, they're ordinarily executed much faster and this will increase the overall speed of your website.

IonCube in Shared Web Hosting

When you purchase a shared web hosting plan from us, it will be created on our tailor-made cloud hosting platform where ionCube Loader is already installed, so you will not have any problems to manage any script app which needs the tool in order to function properly. We also provide a few different versions of PHP, therefore if you switch the version, you'll need to activate ionCube once again. Our system remembers the changes you make, so when you move back to the earlier release of PHP which was active for your account, ionCube Loader will already be enabled. The PHP version as well as the ionCube tool can be managed from the PHP Configuration part of our Hepsia website hosting Control Panel. Any adjustment that you make takes literally just a mouse-click and it will take effect instantly.

IonCube in Semi-dedicated Servers

Because all the semi-dedicated server accounts are set up on our advanced cluster platform and ionCube Loader is available on it, you shall be able to use any script app that needs the software tool so as to work properly. With just a few clicks in your Hepsia hosting Control Panel you can activate or deactivate ionCube for the PHP version which is currently active for the account. Because we support a couple of releases of PHP at the same time, you will have to do this any time you move to a different version, and if you revert back to a release that you have already used, our system will remember your preference and ionCube Loader will already be activated. When you have a couple of sites in the same account and they need different releases of PHP, you can create a php.ini file in each and every domain folder and with several lines of code you're able to define both the PHP release plus the status of ionCube regardless of what is selected for the web hosting account altogether.